实时搜索: jdbc驱动包在哪里

jdbc驱动包在哪里

634条评论 4542人喜欢 6442次阅读 315人点赞
那为什么开发javaweb项目时候,写jdbc不用导入数据库驱动的 jar包? , javax.servlet.ServletException: java.lang.ClassNotFoundException: com.microsoft.jdbc.sqlserver.SQLServerDriver , 我用eclipse写的代码,在eclipse中运行都很ok
但是用jar cvfm打好包后,在cmd下执行打好的包,也能启动执行,但是当运行到需要连接数据裤的部分时,cmd窗口就会打印出:oracle.jdbc.driver.oracledriver
也不是报错,我自己的...

maven怎么添加sqlserver的jdbc驱动包: <dependency>
    <groupId>com.microsoft.sqlserver</groupId>
    <artifactId>mssql-jdbc</artifactId>
    <version>6.2.1.jre8</version>
    <scope>test</scope>
</dependency>

微软的mssql jdbc包,这个是for jre8的。

可以去mvnrepository.org上按需搜索jar包。

SQL Server JDBC驱动中sqljdbc.jar和sqljdbc4.jar包的区别: sqljdbc.jar 类库提供对 JDBC 3.0 的支持。
sqljdbc4.jar 类库提供对 JDBC 4.0 的支持。它不仅包括 sqljdbc.jar 的所有功能,还包括新增的 JDBC 4.0 方法。
sqljdbc4.jar 类库要求使用 6.0 或更高版本的 Java 运行时环境 (JRE)。在 JRE 1.4 或 5.0 上使用 sqljdbc4.jar 会引发异常。
注意: 如果应用程序必须在 JRE 6.0 上运行,即使该应用程序不使用 JDBC 4.0 功能,也应使用 sqljdbc4.jar。

在开发Java 项目时,进行JDBC 操作,要导入数据库驱动包: 怎么不用导入?只是写JAVAWEB项目时,只要把JAR包放到TOMCAT的LIB目录里,就可以不改环境变量。但是写代码的时候,还是得加载驱动的。

java jdbc数据库驱动包在哪个位置了: 不同的数据库针对Java开发调用都提供了相应的驱动,一般命名为*.jar,所在的位置一般是lib目录中。如果是在window下开发,也没有驱动,则可以通过ODBC,然后通过JDBC-ODBC的方式与数据库通信。

如何在JDBC中使用.properties文件配置驱动: 使用JDBC可以对数据库进行增、删、改、查(CURD:创建(Create)、更新(Update)、读取(Retrieve)和删除(Delete))操作,需要配置驱动文件,才能够使用JDBC的功能。可以直接在java代码种配置驱动,方法如下:

第一步:导入jar包 在src文件夹下建立lib文件夹,用于放置驱动jar包。根据jdk的版本选择不同的jar包。例如我使用的是jdk1.6版本,我选择的是ojdbc6.jar。选中jar包,单击右键,选择build path,成功创建访问路径之后就可以添加驱动了;

第二步:添加驱动

需要配置如下信息:
driver = oracle.jdbc.driver.OracleDriver
url = jdbc:oracle:thin:@localhost:1521:orcl
user = scott
password = tiger

SQL Server JDBC驱动中sqljdbc.jar和sqljdbc4.jar包的区别: 本文主要介绍SQL Server JDBC驱动中sqljdbc和sqljdbc4的区别。
sqljdbc.jar 类库要求应用 5.0 版的Java运行时环境 (JRE)。连接到数据库时,在 JRE 6.0 上应用 sqljdbc.jar 会引发异常。
注意: SQL Server JDBC Driver 2.0 不支持 JRE 1.4。应用 SQL Server JDBC Driver 2.0 时必需将 JRE 1.4 升级至 JRE 1.5或更高版本。
sqljdbc4.jar 类库要求应用 6.0 或更高版本的 Java 运行时环境 (JRE)。在 JRE 1.4 或 5.0 上应用 sqljdbc4.jar 会引发异常。
注意: 假如实际运用程序必需在 JRE 6.0 上运行,即使该实际运用程序不应用 JDBC 4.0 功能,也应用 sqljdbc4.jar。
二、为了支持向后兼容以及可能的升级方案,JDBC Driver 2.0 在每个安装包中都包括 2 个 JAR 类库:sqljdbc.jar 和 sqljdbc4.jar。
sqljdbc.jar 类库提供对 JDBC 3.0 的支持。
sqljdbc.jar 类库要求使用 5.0 版的 Java 运行时环境 (JRE)。连接到数据库时,在 JRE 6.0 上使用 sqljdbc.jar 会引发异常。
注意: JDBC Driver 2.0 不支持 JRE 1.4。使用 JDBC Driver 2.0 时必须将 JRE 1.4 升级至 JRE 5.0 或更高版本。在某些情况下,您可能需要重新编译应用程序,因为它可能与 JDK 5.0 或更高版本不兼容。有关详细信息,请参阅 Sun Microsystems 网站上的文档。
sqljdbc4.jar 类库提供对 JDBC 4.0 的支持。它不仅包括 sqljdbc.jar 的所有功能,还包括新增的 JDBC 4.0 方法。
sqljdbc4.jar 类库要求使用 6.0 或更高版本的 Java 运行时环境 (JRE)。在 JRE 1.4 或 5.0 上使用 sqljdbc4.jar 会引发异常。
注意: 如果应用程序必须在 JRE 6.0 上运行,即使该应用程序不使用 JDBC 4.0 功能,也应使用 sqljdbc4.jar。
请注意,尽管驱动程序旨在与所有主要的 Sun 等效 Java 虚拟机一起工作并由这些虚拟机支持,但却是在 Sun JRE 5.0 或更高版本上进行测试的。
JDBC Driver 专为使用 SQL Server 2005 引入的功能而设计,但它也可以向后兼容 SQL Server 2000(包括 64 位版本)。
重要提示: Microsoft SQL Server JDBC Driver 2.0 可以连接到 SQL Server 2008,但不完全支持 SQL Server 2008 中新引入的数据类型或其他功能。

已经导入jdbc驱动包了,还是有问题,求解决,几天了,烦死了: 你写错了,应该是
com.microsoft.sqlserver.jdbc.SQLServerDriver
注意上面都是半角

看到没有,jdbc和sqlserver写反了

在cmd中执行jar包时,显示oracle.jdbc.driver.oracledriver: 这是因为jar包内找不到ojdbc14.jar的原因。
如果程序引用了外部jar包,需要将外部jar解压到%Classes%目录,例如%project%/bin.
然后就可以利用jar cvfm命令打包了。

当然在Eclpse中还有一种更简便的方法,就是利用fat 导出jar,它会自动帮您完成上面的操作。
fat下载地址:http://fjep.sourceforge.net/#inst

  • ok卡哪里可以用

    2010cad带图框出图视频: 通用版图框在绘图前先选择绘图模板将图框调入。autocad electrical绘图选择菜单命令新建-弹出模板窗口-选择需要的绘图模板如ACE_GB_a3-确定所选的模板就进入窗口绘图区了,接下来简单设置一下就可以绘...

    729条评论 2877人喜欢 3047次阅读 882人点赞
  • 062是哪里

    我摩托车被扣,发票丢了,交警让开证明,证明应该怎么写: 这个证明应该是到你购买摩托车的经销商去,让老板帮忙开,盖车行的公章。 ...

    962条评论 3534人喜欢 1637次阅读 320人点赞
  • 0572哪里的区号

    违章停车被贴条交警把车身颜色写错罚款该交不该交: 这样就可以提出复意了。去重新核查 ...

    210条评论 1614人喜欢 4432次阅读 445人点赞
  • dnf地轨中心在哪

    cad怎么编辑块: 有四种方法:1.直接对块双击2.右键,编辑块或在位编辑3.工具栏上 块编辑器,然后选择块4.输入命令bedit,然后选择块 ...

    902条评论 4111人喜欢 5970次阅读 253人点赞
  • 跳蚤市场是什么意思

    cad有增强性编辑器的块怎么进入块编辑: 你是要编辑这个块还是要编辑内容? 编辑内容很简单,双击就是了。编辑这个块的话,用bedit(或者是REFEDIT)这个命令吧~ ...

    855条评论 6659人喜欢 6388次阅读 453人点赞